RIP

No hay comentarios
Rip es un protocolo de enrutamiento vector distancia, el cual utiliza como métrica el conteo de saltos para seleccionar el mejor camino hacia la red destino.
Cada router por el cual tendrá que pasar el paquete se le llama salto, teniendo como máximo 15 saltos, siendo 16 inalcanzable.
Existen la versión 1 y 2 de este protocolo de enrutamiento, La versión 1 de este protocolo de enrutamiento utiliza mensajes broadcast para actualizar a sus vecinos. Ademas también es protocolo classful, lo que significa que no envía la red con su mascara de subred en sus actualizaciones, lo que es un problema cuando existen redes discontiguas o con uso de un VLSM. 
La distancia administrativa se utiliza para establecer una prioridad del protocolo de enrutamiento cuando existen mas de uno corriendo, si ambos conocen la misma red se da preferencia al de menor distancia administrativa. Rip posee un valor de 120 para ambas versiones.

Las actualizaciones de Rip son periódicas y se envían siempre cada 30 segundos, enviando su tabla de enrutamiento completa.
Rip versión 2 envía las actualizaciones de enrutamiento a sus vecinos utilizando la dirección multicast 224.0.0.9 , enviando la red y su mascara (es decir classless), solucionando así el problema del VLSM. 

Rip usa Horizonte dividido, lo que significa que al recibir una actualización por una interfaz, no vuelve a enviar dicha actualizacion por la interfaz que fue recibida; ademas usa envenenamiento en reversa para prevenir el problema de contador al infinito. El concepto envenenamiento de ruta se utiliza para avisar que una ruta es inalcanzable, enviando una actualización de la ruta con un costo de 16 saltos (inalcanzable). Ademas Rip puede mantener hasta 6 caminos hacia una misma red con un mismo costo, realizando balanceo de carga entre los distintos caminos hacia el destino.

Finalmente los Update son cada 30 segundos, el Invalid time es 180 segundos, Holdown 180 segundos y Flush timer 240 segundos.

A continuación un paso a paso de RIP:

En la siguiente topologia se aplicaron los comandos:

ROUTER 1
enable
configure terminal
interface fa 0/0
ip address 192.168.1.1 255.255.255.0
no shutdown

interface serial 0/0
ip address 192.168.2.1 255.255.255.0
no shutdown

router rip
version 2
network 192.168.1.0
network 192.168.2.0

ROUTER 2
enable
configure terminal
interface fa 0/0
ip address 192.168.1.1 255.255.255.0
no shutdown

interface serial 0/0
ip address 192.168.2.1 255.255.255.0
no shutdown

router rip
version 2
network 192.168.1.0
network 192.168.2.0

Imagen

Router1
Rip envia un mensaje multicast 224.0.0.9 a sus interfaces que hacen match con el comando #network 192.168.3.0 y #network 192.168.2.0 , en este caso la interfaz F0/0 y S0/0. Tambien identifica que redes serán publicadas en las actualizaciones de rip. Primero rip avisa a que interfaz habla rip enviando este primer mensaje a Router2.

Imagen

Router2 al igual que Router1 identifica que interfaces hablan rip con el comando #network 192.168.1.0 y #network 192.168.2.0 . Al recibir un mensaje por la interfaz  que identifica que habla Rip, le responde con sus redes que conoce y que hacen match con el comando network. En este caso Router2 le envía la 192.168.1.0 y 192.168.2.0, a pesar de que Router1 ya conoce la 2.0. Es decir Rip envía su tabla de enrutamiento completa.

Imagen

Finalmente Router1 recibe el mensaje multicast con las redes anunciadas por 192.168.1.0 y 192.168.2.0. Pero devido a que Router1 ya pasee la 192.168.2.0 directamente conectada, no la agrega a su tabla de enrutamiento  solo agrega la 192.168.1.0. Estos mismos pasos se repiten por Router2 para agregar la red 192.168.3.0 a su tabla de enrutamiento.

Anunciando redes

En la siguiente topologia se muestra que redes deberían anunciar los routers cuando trabajan con RIP.
Router R1 le anuncia a R4 las redes que posee directamente conectada hablando RIP excepto la que esta conectada a él, es decir red A-B
Router R1 tambien la anuncia a R2 las redes B – C
Router R4 anuncia a R3 las redes A – B – C
Router R4 al mismo tiempo le anuncia a R1 la red que posee directamente conectada tamvien, es decir la red D
Router R1 recibe la red D y se la anuncia a R2
Router R2 finalmente recibe la red D

Imagen

Anunciando una nueva red

En la siguiente topología se muestra como responde RIP ante una nueva RUTA.
Toda la RED a convergido, y en R1 se agrega una nueva LAN (192.168.1.0/24). R1 anuncia esta nueva red por todas las interfaces que hablan RIP, en este caso FA0/0, S0/0 y S0/1. Ya que en R1 no existe niun dispositivo hablando RIP nadie responde, sin embargo R1 anuncia esta nueva red a R2 y a R4, y a su vez R2 y R4 anuncian la nueva red a R3.

Imagen

Imagen

Caída de una red

Cuando una Red se cae, el router que posee la ruta perdida tiene que avisarle a sus vecinos, por lo tanto R1 le anuncia a R2 y a R4 que la ruta ya no se encuentra disponible, enviandole la ruta con metrica 16 (inalcanzable), finalmente R2 y R4 le anuncian a R3 la red 192.168.0.0/24 con metrica 16.

Imagen

Imagen

Responder

Introduce tus datos o haz clic en un icono para iniciar sesión:

Logo de WordPress.com

Estás comentando usando tu cuenta de WordPress.com. Cerrar sesión /  Cambiar )

Google+ photo

Estás comentando usando tu cuenta de Google+. Cerrar sesión /  Cambiar )

Imagen de Twitter

Estás comentando usando tu cuenta de Twitter. Cerrar sesión /  Cambiar )

Foto de Facebook

Estás comentando usando tu cuenta de Facebook. Cerrar sesión /  Cambiar )

w

Conectando a %s